https://www.growthbook.io/ logo
#give-feedback
Title
# give-feedback
w

worried-lawyer-21676

08/15/2023, 8:23 AM
Hi everybody! With ClickHouse as data backend, I'm often getting "out of memory" error, such as one on the picture. Apart from increasing memory on my ClickHouse what can I do to fix it? [Curiously, the ClickHouse has 32 GB of RAM, and somehow the limit is less than 10 GB] Is it possible that GB is generating "not the most optimal" queries, and is there a way to improve it (tune) for me as a user?
h

helpful-application-7107

08/15/2023, 3:02 PM
Some things you can do: 1. Try to ensure your experiment assignment and metrics tables are date partitioned. 2. Test whether the query partitions are being used by adding
WHERE <YOUR_DATE_COLUMN> >= '{{ startDate }}' AND <YOUR_DATE_COLUMN> <= '{{ endDate }}'
to your queries, in the off chance that our own date filters are not properly hitting your partitions (see more here: https://docs.growthbook.io/app/datasources#sql-template-variables) 3. Consider whether 10GB is really a good minimum? Given many of our user's data sizes, a 10GB minimum could be pretty limiting.
w

worried-lawyer-21676

08/16/2023, 10:06 AM
Thanks, I'll try the step number 2 first
@helpful-application-7107 Thank you, number 2 helped with combination of disabling of Activation Metric in the experiment settings
🙌 1
9 Views