https://www.growthbook.io/ logo
#announcements
Title
# announcements
s

some-fireman-7578

08/30/2023, 7:03 PM
Hey guys, I'm trying to use GA4 with BQ as database in Growthbook, but I'm having this error before start the experiment. I think that the error could be the table events* we use a wildcard, so it's different, but I do not know how to change this. Anyone knows how could I fix this?
f

fresh-football-47124

08/30/2023, 7:04 PM
is this a new data source?
did you add the project id and dataset id?
you can edit that query from metrics & data -> data sources
s

some-fireman-7578

08/31/2023, 10:10 PM
Sorry my late, Graham! I solved the last problem with your help, but now, I got this message when I try to run an experiment again. Maybe this could be set in a different part of our project, but I didn't realize where.
where 'my_dataset' is defined?
I'm setting both fields in dataset screen.
f

fresh-football-47124

08/31/2023, 10:12 PM
editing them after you’ve created the data source, won’t udate the sql queries
so you’ll have to edit it in the assignment query sections
s

some-fireman-7578

08/31/2023, 10:19 PM
So I need to create the metrics from 0 or a new experment?
I create the metrics again, but still get this message
f

fresh-football-47124

08/31/2023, 10:21 PM
yes, that doesnt look right
what is the query?
s

some-fireman-7578

08/31/2023, 10:21 PM
image.png
f

fresh-football-47124

08/31/2023, 10:21 PM
the project id and dataset id usually have numbers
do you have access to bigQuery?
s

some-fireman-7578

08/31/2023, 10:31 PM
Yes. When I click to see the schema, I can see without problems
I create my experiment and when I go to see the results with the metrics choosed, I got this
f

fresh-football-47124

09/01/2023, 8:12 AM
correct
the schema browser uses the settings in the connection info
but each query will have <project id>.<dataset id>.events_* in it
and in your case, those values are wrong either in the metric query, or the assignment query
(or both)
11 Views