https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
e

eager-wall-93028

04/12/2023, 12:15 PM
Hey 👋 Could someone help me with the error I get when applying dimensions to my experiment results? So I’m using Amazon Redshift and apparently it encounters error with concat function, which is used in Growthbook’s query.
Copy code
REGEXP_REPLACE(
  MIN(
    CONCAT(
      cast(e.timestamp as varchar),
      '____',
      coalesce(cast(e.dimension as varchar), '__NULL_DIMENSION')
    )
  ),
  '.*____',
  ''
) as dimension,
f

fresh-football-47124

04/12/2023, 3:26 PM
Interesting
e

eager-wall-93028

04/13/2023, 9:10 AM
Hey @fresh-football-47124 is there a way to fix it? This query was generated by Growthbook and I have no power over it. I get the same error when running it in IDE. Just to give more context, I’ve declared session_marketing_source dimension in assignment query and it throws error when applying this dimension to the experiment results. There’s a same topic in Github: https://github.com/metabase/metabase/issues/12544
f

fresh-football-47124

04/13/2023, 9:31 AM
We’re working on a fix
e

eager-wall-93028

04/13/2023, 9:52 AM
Great news, thank you very much! If you have an ETA for it, I’d be glad to know
Also @fresh-football-47124 I’m not sure why, but this is only applicable to dimensions that were specified in assignment query. Dimensions from ‘Dimensions’ tab seem to work
h

helpful-application-7107

04/13/2023, 8:22 PM
Hi Katerina. This is a problem on redshift with some special handling we added to use the first dimension value per user as part of our SQL refactor. This "first" notion only applies to assignment query dimensions (which have a timestamp) and not user dimensions (which do not have a timestamp; for those we just use the MAX dimension and instead ask users to only have a 1:1 user to dimension mapping). So we need to fix this logic for the assignment query dimensions and we know how to do so. Just give us a second to test it.
As for an ETA, we should land a fix tomorrow pacific time.
e

eager-wall-93028

04/14/2023, 2:03 PM
Hey Luke, thanks a lot for explaining 🙌
h

helpful-application-7107

04/18/2023, 4:55 PM
Hey Katerina! Can you let us know if the fix we landed on Friday worked for you?
e

eager-wall-93028

04/19/2023, 4:22 PM
Hey Luke, I’ve checked and it works, thank you!
🙌 1
10 Views