https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
b

blue-agent-15067

05/18/2023, 12:57 PM
Hi, we are testing GrowthBook and setting up datasources to analyse experiment. we are setting them up in bigquery. Although I get that you need to have experiment assignment queries and metrics living in the same datasource, we are still struggling to set up a datasource with multiple datasets in it. The UI asks for a default dataset, but then there is only that one, even if the project (on bigquery) contains multiple datasets. In our case, I common to have multiple datasets coming from different business units (e.g. to track offline conversions) and then datasets that track online behaviors (e.g. Google Analytics). can someone help me out to understand if we are missing something?
@colossal-dream-20188
f

fresh-football-47124

05/18/2023, 1:49 PM
you can project scope and/or use tags to help you keep things organized
are you having trouble creating the queries themselves?
b

blue-agent-15067

05/18/2023, 1:59 PM
actually, in the UI of the datasource we see only one dataset
BI_prod_marketing
(the one we defined as "default" in the config), while, in fact for that specific datasource there are many.
f

fresh-football-47124

05/18/2023, 2:18 PM
those are tables though, right?
b

blue-agent-15067

05/18/2023, 2:22 PM
those on the bigquery screenshot are
datasets
(under the same project) each one containing
views
f

fresh-football-47124

05/18/2023, 2:23 PM
ah, the query editor is showing extra datasets
b

blue-agent-15067

05/18/2023, 2:27 PM
so you mean that in the UI I see only the default, while I can access the other ones through a query?
f

fresh-football-47124

05/18/2023, 2:29 PM
ah, I think the other way around
but you’re problem is that your connected to one dataset, and the sql editor give you more datasets that you don’t want to use?
b

blue-agent-15067

05/18/2023, 2:35 PM
no, actually the problem that I was facing seemed that it was not actually a problem... when I tried to configure an
Experiment Assignment Query
pointing to a table not shown in the UI, I managed to get data
so it may be ok! 🙂
this UI in particular was misleading to us: it showed us only the schema for the default dataset although is possible to query other datasets under the project
Thanks @fresh-football-47124 at the moment the issue seems solved 🙂
13 Views