https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
d

delightful-waitress-86518

06/16/2023, 3:08 PM
Hi! I have a question about local self-hosted GB via docker compose. From time to time it’s just hanging on
<http://localhost:3100/auth/refresh>
endpoint, so i need to restart container. Logs doesn’t show any useful information. Any ideas how to fix that? ENV: apple M1, custom ports for app origin host
Copy code
yarn run v1.22.19
$ wsrun -p 'back-end' -p 'front-end' --no-prefix -c start
$ next start
$ node dist/server.js
ready - started server on 0.0.0.0:3000, url: <http://localhost:3000>
{"level":30,"time":1686927154940,"pid":61,"hostname":"a1e71a11d95f","msg":"No config.yml file. Using MongoDB instead to store data sources, metrics, and dimensions."}
(node:61) [MONGOOSE] DeprecationWarning: Mongoose: the `strictQuery` option will be switched back to `false` by default in Mongoose 7. Use `mongoose.set('strictQuery', false);` if you want to prepare for this change. Or use `mongoose.set('strictQuery', true);` to suppress this warning.
(Use `node --trace-deprecation ...` to show where the warning was created)
{"level":30,"time":1686927156312,"pid":61,"hostname":"a1e71a11d95f","msg":"Back-end is running at <http://localhost:3100> in development mode. Press CTRL-C to stop"}
yarn run v1.22.19
$ wsrun -p 'back-end' -p 'front-end' --no-prefix -c start
$ node dist/server.js
$ next start
ready - started server on 0.0.0.0:3000, url: <http://localhost:3000>
{"level":30,"time":1686927439560,"pid":59,"hostname":"a1e71a11d95f","msg":"No config.yml file. Using MongoDB instead to store data sources, metrics, and dimensions."}
(node:59) [MONGOOSE] DeprecationWarning: Mongoose: the `strictQuery` option will be switched back to `false` by default in Mongoose 7. Use `mongoose.set('strictQuery', false);` if you want to prepare for this change. Or use `mongoose.set('strictQuery', true);` to suppress this warning.
(Use `node --trace-deprecation ...` to show where the warning was created)
{"level":30,"time":1686927440767,"pid":59,"hostname":"a1e71a11d95f","msg":"Back-end is running at <http://localhost:3100> in development mode. Press CTRL-C to stop"}
b

brief-beach-53809

07/24/2023, 5:16 PM
I’ve got the same issue, are you manage to solve this?
16 Views