https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
a

agreeable-activity-31366

10/02/2023, 1:54 PM
Hi team! Was able to launch my first visual experiment last week, and have since then been waiting on data to show up.. Waiting patiently for hte first couple of days, as we don't have streaming enabled in our GA4/BQ setup, but now after a week safe to say there is another issue.. How can I make sure the experiment is tracking properly? Everything looks good in the Data source and metrics config, and the experiment should be receiving plenty of traffic and conversions.. Any guidance would be appreciated🙏
h

helpful-application-7107

10/02/2023, 3:46 PM
Can you view the queries using the three button menu to the right, clicking "view queries" and then trying to see what part of them may be returning no data? You can also paste them into bigquery and run them directly there to help debug.
a

agreeable-activity-31366

10/03/2023, 9:03 AM
@helpful-application-7107 Thanks for the reply. Checked the queries, and get "no rows returned" on all 3 metrics I've set up.. Ran the queries in BQ with not data returned..
What's next step in troubleshooting? STrange because the metrics were set up through "Discover metrics" when the data source was configured..
h

helpful-application-7107

10/03/2023, 3:28 PM
Then my guess is that you're seeing some problem joining the IDs from your experiment to your metrics. If you can share your queries here with me or in a DM I can tell you which sub-queries to run to try and troubleshoot.
16 Views