https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
e

echoing-park-17810

10/10/2023, 8:40 PM
HELLO! 🙂 I'm making visual changes to each URL. Am I doing this correctly? I have ensured that the URL targeting is accurate, but I'm not seeing any visual changes on each preview. However, in the visual editor, it does reflect my changes.
s

swift-helmet-3648

10/10/2023, 11:03 PM
Hi, do you have the SDK set up and configured correctly on your page? The preview feature won't work until that is working.
e

echoing-park-17810

10/11/2023, 9:04 AM
yes it is @swift-helmet-3648 🙂 we made couple of tests and it works. but that screenshot I shared don't 😐
s

swift-helmet-3648

10/11/2023, 3:17 PM
Have you tried opening a preview and taking a look at the GrowthBook Devtools panel to help debug? It may identify why the experiment is not loading
You can access it by opening chrome devtools and navigating to the 'Growthbook' panel. (I'm assuming you already have it installed since you're using the visual editor!)
e

echoing-park-17810

10/11/2023, 3:42 PM
@swift-helmet-3648
what does this mean?
s

swift-helmet-3648

10/11/2023, 3:51 PM
'Skip because inactive' shows up when the experiment is in draft state, which makes sense...
You're receiving the experiment, which also makes sense. And what is the visual change you're expecting to see? Is it not showing up?
Sorry - I'm noticing there is a bug with the DevTools now, where it won't show the multiple visual changesets (which you have three)
I suspect it has to do with your URL targeting. Do previews work for any of the pages? Your first one has Regex URL targeting - is that intended?
e

echoing-park-17810

10/11/2023, 4:04 PM
it only works on the last one, the regex thing, I'm just testing it because I suspect it has something to do with targetting
16 Views