Hey, I faced with the issue that GrowthBook gener...
# ask-questions
Hey, I faced with the issue that GrowthBook generates wrong database name concatenating project ID twice in an experiment results. Example:
Copy code
SELECT ... FROM `project-id`.`project-id.dataset-id`
So then query simply fails with
Invalid project ID
Is there any suggestions how to fix that?
Hi Evgenij. I have the same issue
@fresh-football-47124 Can you take a look please? We cant get our experiment results from BQ because of that issue
Hi - when you first enter the project id and data set id, we create the default queries for you. While you can update that info (by clicking edit connection from the data source page), it will not regenerate existing queries. You can edit any of the queries manually to fix the project ids that might be wrong
@fresh-football-47124 I think problem only with query in this experiment update function. Everywhere else connection looks good. Please take a look at this screen record: https://somup.com/c06YbMBJUd
You might have to edit the "Experiment Assignment" queries in the data source setting to remove the duplicate project id.
I ddi that and in experiment update function it started to work But now its giving me error on Experiment Assignment query and I cant get it back as it was
It actually worked @future-teacher-7046 Thank you for the tip! With this final issue solved we upgraded to Pro version! It will be great if someone can make a demo for us to show all the features of the platform. But so far I’m so excited to use it