https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
c

cuddly-kilobyte-92191

12/20/2023, 1:35 PM
Hi team! I'm having an error
Unknown experiment assignment table - anonymous_id
in my two first experiments (Assignment Attribute of the 1st - user_id, Assignment Attribute of the 2nd - user_pseudo_id which is user_pseudo_id in my case) I tried to add new "Experiment Assignment Query", but I can't add the same query as I already have with user_id. Will attach the screenshot of my Data Source and the error in the first comment
Screenshot 2023-12-20 at 21.32.02.png,Screenshot 2023-12-20 at 21.33.45.png
b

brief-honey-45610

12/20/2023, 1:41 PM
Hi Aksinia 👋 Thanks for providing all the info! Are you certain that the table name and schema you are using in the query is correct, and that it matches what is in BigQuery? Are you able to send a screenshot of the column names in this table in BigQuery?
Maybe the column name is experiment_viewed instead of viewed_experiment? The error message seems to be complaining about the column name specifically so I’m trying to pin down what could be happening.
Your BQ instance is hosted in the US, right?
c

cuddly-kilobyte-92191

12/20/2023, 1:50 PM
Maybe I misunderstood something, I haven't created anything yet. Should I create an empty table in BigQuery in advance with 5 columns - user_id, user_pseudo_id, timestamp, experiment_id and variation_id? I'm looking at https://docs.growthbook.io/event-trackers/freshpaint#experiment-assignment-queries
b

brief-honey-45610

12/20/2023, 2:40 PM
Ahhh OK! Yes, the SQL code in the Experiment Assignment Query needs to match table name(s) and columns in BQ. You’ll need to create the table in BQ using your desired column names, and edit the Experiment Assignment Query in GrowthBook to match what you’ve specified for the table.
c

cuddly-kilobyte-92191

12/20/2023, 3:03 PM
Thank you! Made a table, but still have this error
Unknown experiment assignment table - anonymous_id
, and also not sure if Assignment Queries work properly, even though I have a table 'growthbook_view_experiment' now
looking 1
b

brief-honey-45610

12/20/2023, 3:25 PM
I think GrowthBook is still trying to access a table called ​`anonymous_id`​, which likely does not exist. Usually
anonymouse_id
is a column in the query if it's being used as an identifier, but I can see from your screenshots that you are using
user_id
and
user_pseudo_id
as identifiers instead. Do you have any occurrences of
anonymous_id
in any of your GrowthBook-related code?
Could you please also double-check that the experiment assignment query in question is linked to the correct experiment?
Are you using both Google Analytics and Big Query?
c

cuddly-kilobyte-92191

12/20/2023, 3:57 PM
All of my code is in Fact table and metrics. Don't use anonymous_id anywhere there How can I check if the experiment assignment query is linked to the experiment? Adding a screenshot of my both experiments. Yes, we're using Google Analytics and BigQuery, but I create metrics only from BigQuery
looking 1
h

helpful-application-7107

12/20/2023, 4:05 PM
Hey Aksinia, so sorry for the confusion. I think if you go to your Experiment, go to the Results Tab, and click "Analysis Settings" at the top of the results tab, you'll be able to set your "Experiment Assignment Table". Once you pick the right table, I think this problem might be resolved.
c

cuddly-kilobyte-92191

02/12/2024, 2:01 PM
Hi @brief-honey-45610 and @helpful-application-7107, I ran some test experiments - on user_id (logged in users) and user_pseudo_id (unlogged users). With logged in users the results somehow started to count, but with unlogged users the error comes out -
Missing identifier join table for 'user_pseudo_id' and 'user_id'
. I’m attaching a screenshot of the experiment assignment queries, the experiment settings and my experiment_viewed table. Could you please tell how and for what do I need to connect these identifiers?
4 Views