https://www.growthbook.io/ logo
#ask-questions
Title
# ask-questions
g

gorgeous-midnight-57657

08/03/2023, 5:23 AM
Hello, We are starting out with Growthbook experiments <>GA4 for A/B testing. We’ve added the tracking call back and are testing on a preproduction environment. We can now see the
experiment_viewed
event on the GA4 and and also with direct queries to BigQuery. However the experiment on Growthbook still returns “No data yet. Make sure your experiment is tracking properly.” I copied out the metric query to run directly on Bigquery and it only produces results when I remove one of the
Where
clauses
_TABLE_SUFFIX BETWEEN '20230727' AND '20230802'
Could this be because my experiment data is all in the
.events_intraday_20230802
table ?
Taking out the where clause in my experiment assignment solved this
f

fresh-football-47124

08/03/2023, 7:27 AM
glad its working
g

gorgeous-midnight-57657

08/04/2023, 8:17 AM
@fresh-football-47124 I’d appreciate your help here - I’m having an issue with setting up dimensions. Following the conversations I’ve seen on the slack group, I tried setting up dimensions from the dimensions tab and also from the Experiment Assignment Queries. Both give me the same result. The dimension I want to set is
device.category
(i.e mobile, desktop, other) . It’s from my device field which is struct.
{
"device": {
"category": "desktop",
"mobile_brand_name": "Apple",
"mobile_model_name": "Safari",
"mobile_marketing_name": null,
"mobile_os_hardware_model": null,
"operating_system": "Macintosh",
"operating_system_version": "Macintosh Intel###",
"vendor_id": null,
"advertising_id": null,
"language": "en-us",
"is_limited_ad_tracking": "No",
"time_zone_offset_seconds": null,
"browser": null,
"browser_version": null,
"web_info": {
"browser": "Chrome",
"browser_version": "115.0#####",
"hostname": ####
}
}
}
When I set the dimension, I get only one grouping, Mobile . I’ve queried the experiment viewed directly and i can see that there are mobile AND desktop users who viewed the experiment. So I’m not sure why the experiment result is only returning Mobile
f

fresh-football-47124

08/04/2023, 8:28 AM
we give the full SQL we use to get that data shown
I have a feeling that due to the very low sample sizes, and a possible interaction with the date range, you’re not seeing any other dimensions
👌 1
g

gorgeous-midnight-57657

08/04/2023, 8:32 AM
we give the full SQL we use to get that data shown
Yes I also see just one grouping when I query BQ directly. Okay. I will try with a larger sample size and if it doesn’t work I’ll resort to creating metrics for each device type. 🤞
Update: We rolled out the experiment on Friday and are getting the correct dimensions data. The issue must have been the low sample size as you mention Graham. Thank you
f

fresh-football-47124

08/07/2023, 7:41 PM
great!
8 Views