Hi there! I was editing one of our features, but a...
# ask-questions
l
Hi there! I was editing one of our features, but am unable to publish the draft due to it being flagged as identical to the previous. Myself and another team member tried to troubleshoot and publish some changes (thus, not making the drafts identical) but are receiving the same error, or a report that there is a conflict. Has anyone else run into this? We're currently unable to publish changes on this feature.
👀 1
h
Hi, are you using Cloud or self hosted? What sort of feature rules are in your draft?
l
Hi @happy-autumn-40938! We are using Cloud, and there is a Forced Value rule. Here's a quick Loom of the currently issue we are facing now: Conflicts in the draft (with no one else having made a change since our last publish.). With the Conflicts, when I do try to Keep my Changes, I am unable to publish (I believe the error there was that only a draft can be published, it was in red text in the bottom left corner after reviewing.) or the same No Changes detected/identical - so, same error as yesterday. I have also attached screenshots showing that the email count goes up by one during our draft (65 Live, 66 in draft). cc: @gifted-queen-1541
g
Hey there! We’ve still been hitting this issue intermittently for the past week (cc: @happy-autumn-40938) Essentially, when I edit the rule in the console it doesn’t let me publish, saying “Draft is identical to the live version. Make changes first before publishing.” There clearly is a change made since the email list count increases from 65 -> 66 (as the screenshots show) Not sure if there is something happening with the versioning? We use this feature for whitelisting so there are multiple team members editing it regularly. Let me know if there’s any other information that would be helpful! Would be great to figure this out since it’s been blocking us from adding users to our whitelist
f
Hello. I see something suspicious in the feature revision log that I think might be causing these issues. I'm trying to reproduce locally and if my hunch is right, it should be an easy fix we can make.
While I investigate, one thing you might want to look into is using Saved Groups. We built this exactly for the use case you have here - a long list of ids/emails used for targeting. https://docs.growthbook.io/features/targeting#saved-groups It will let you update the list of email address without needing to publish the feature flag every time. The Force Rule would just reference the saved group instead and it will be updated and published automatically whenever the group changes.
Ok, this should be fixed now. If you have a draft now in this broken state, you will need to discard it, but then changes should work as intended
🙏 1
🙌 1
Thanks for catching this bug!
r
Noted! thank you @future-teacher-7046
looks like it works for me