Hi. I have set up a/a test in growthbook using vis...
# ask-questions
Hi. I have set up a/a test in growthbook using visual editor for 100% traffic. And I wanted to check how growthbook dev tools works and which group I fall into. However, it showed me that I do not get into the test because of url targeting, but I checked everything and it should have worked. Moreover, users are entering this test, because I can see it in the amplitude and metric variables in growthbook. So what's the reason why growthbook dev tools doesn't show my test hits?
@bright-artist-6236 has opened an issue Close Issue button
Our official support hours are 6:30am - 5pm Pacific Time, Monday through Friday. You may occasionally hear from us outside of these hours. Your support request has been logged in our system. Our support team will get back to you very soon!
Hi, I’ve got your support request in my queue and I’ll follow up as soon as I can
Do you have a Single Page App with client-side routing? If so, make sure you are updating the URL in the GrowthBook instance whenever a navigation occurs:
. If that's still not working, can you share the URL targeting you set up in GrowthBook and the URL of your site where you expect it to work?
And the url pf website is https://unimeal.com/ntrl_sug/step-age
That's the url targeting setup
I have tried to set up different url targeting with '*' but nothing is work
thanks for providing more info. That experiment seems to run fine. I think this is just a bug with devtools. It doesn't seem to be picking up the URL of the page correctly, so when devtools tries to evaluate your expeirment, it fails the targeting, even though it works fine on your actual site. We will take a look and fix this soon